Programmes LOGO

Voici quelques exemples de dessins effectuer avec tortue-logo. N'hésitez pas à soumettre vos propres créations.

Carrés gigognes

pour carre :x
repete 4 [av :x td 90]
fin

pour gigogne :y
carre :y
si :y>5 [gigogne :y-5]
fin

gigogne 200

Gigogne

Etoile

repete 6 [av 100 td 144]

Etoile

Rosace

repete 18 [td 20 repete 18 [td 20 av 20]]

Rosace

Polygone

pour forme :nb :long
repete :nb [av :long tg 360/:nb]
fin

pour dessine :nb :long
forme :nb :long
si :nb<12 [dessine :nb+1 :long]
fin

dessine 3 100


polygone

x